WordPress 3.0 : Missing zlib Extensions

Sure WordPress I’ll click on your annoying “WordPress 3.0 is available!” option… On a new install only! Luckily for me I don’t trust many things right off the bat, and I had looked into the WP forums before hand to know that many people were having problems and it was taking their site down. I, probably like many of you reading this, have extra domains not doing much.

I installed my default installation of WP 2.9.2 on gave the install a whirl to see how things go. But first update your plugins… 3 seconds later, “this site is being updated!” Wait a few more minutes, just in-case things are happening in the background. Nothing. No website, no admin, no new files on the server. Good times!

I then manually downloaded WP3.0 and uploaded it. Which partly worked. I had to do the database update, which I expected. But I still have an annoying message from WP: “An automated WordPress update has failed to complete.” Try it again. New message: “Abort class-pclzip.php : Missing zlib extensions”. Luckily for me I keep the PHP install directory ready to go in the event something needs to change. I also create a PHP install script so I don’t have to retype my install configuration. It is nothing more than a text file with 2 lines:

make clean

./configure <myswitches>

This makes it real easy to modify anything. This time I added –with-zlib and recompiled.